PDA

View Full Version : Bot Run-time/Calibration Troubleshooting Checklist



RiD
04-25-2020, 10:21 PM
Check map is created correctly. When creating a map, compass must be facing North. The bot will piece together a map as you walk around the area, creating one image (aka zone) per area. So if you teleport or go up a ladder, you will have multiple zones. You must have only one zone per in-game area. If not, or if path is wrong, try again. This time walking more slowly. If your map isn't setup correctly your bot will not calibrate correctly.


Double-check gfx settings (https://www.robotzindisguise.com/forum/showthread.php?25876-The-Required-GFX-settings). In particular, make sure mouseover menus are off. Mouseover menus will obstruct the bot's visual processing, leading to calibration errors and unexpected behavior.


Don't zoom-in too much. On RS, around mid zoom is ideal, or 3/4, but avoid maximum. If world items are too large it is harder for the bot do differentiate between foreground and background.


Set the blue grid correctly (https://www.robotzindisguise.com/forum/?pageid=botcp&b=9&c=0#22) before every calibration. The blue grid is essential for finding items within the 3D world. To verify you've set it up properly, open the bot GUI, click the world item, and check the highlighted area on the map matches up with the location of the item in-game.


Wait till AFTER the third beep to start calibrating.


DO NOT start calibration halfway through a navigation action, the whole path needs to be seen by the bot, otherwise it is likely to take a straight line path to the destination, which may not be ideal.


During calibration, avoid clicking NPCs/World-Items at the very edge of the window, and on RS3-Retro, don't click NPCs/World-Items outside the designated area (https://www.robotzindisguise.com/forum/showthread.php?25876-The-Required-GFX-settings).


If your Log is reporting errors finding world item, try editing World Items from the bot GUI.


If you still have problems after all the above. Post details of your issue (for example, a picture of the bot GUI from your calibration, or pictures showing in-game gfx settings) and ask for help in Genesis Help (https://www.robotzindisguise.com/forum/forumdisplay.php?122-Genesis-Help).